Back to overview
Degraded

clictopay-service is down

Dec 09 at 04:48pm CET
Affected services
clictopay-service

Resolved
Dec 09 at 04:54pm CET

clictopay-service recovered.

Created
Dec 09 at 04:48pm CET

clictopay-service is degraded.