Back to overview
Degraded

clictopay-service is down

Nov 10 at 12:14am CET
Affected services
clictopay-service

Resolved
Nov 10 at 12:17am CET

clictopay-service recovered.

Created
Nov 10 at 12:14am CET

clictopay-service is degraded.