Back to overview
Degraded

clictopay-service is down

Nov 03 at 07:38am CET
Affected services
clictopay-service

Resolved
Nov 03 at 07:41am CET

clictopay-service recovered.

Created
Nov 03 at 07:38am CET

clictopay-service is degraded.