Back to overview
Degraded

clictopay-service is down

Sep 15 at 11:30pm CEST
Affected services
clictopay-service

Resolved
Sep 15 at 11:36pm CEST

clictopay-service recovered.

Created
Sep 15 at 11:30pm CEST

clictopay-service is degraded.